Skip to content

RVCManager Quick Start

Software Installation

Requirements

System Requirements

Recommended Minimum
System 64-bit Windows 10/Debian 10/Ubuntu 18.04 or above 64-bit Windows 10/Debian 9
Processor Intel i7 Intel i5
RAM 16GB 8GB

Network Requirements

  • Recommended: Intel PCIe Gigabit NICs (electrical, copper), e.g. Intel I350, Intel 82571, 82545, 82576, etc.

  • Not recommended: Realtek NICs (all series), some Intel NICs (such as Intel 82574L, Intel Pro/1000PM, etc.).

For network cards that are not listed, effects will be dependent on the actual trial results.

CUDA Version Requirements

  • Graphics card: NVIDIA GTX 980 or better

  • CUDA version: CUDA 11.1 or above

Download and Installation

Visit RVBUST download center at http://rvbust.com/en/download.html to download the installation package for the adapted system. If RVCManager is already installed, it is recommended to delete the SDK folder and reinstall it when updating the software version.

Installation Steps

Windows: Double-click the installation package file and follow the wizard to complete the installation of software and drivers.

Linux: Go to the path where the installation package is located and run the following commands to complete the software installation. Please modify the command according to the version name of the package you downloaded.

sudo dpkg -i RVCSetup_(version)_(date)_(type).deb

Tip

For common installation problems, please see Troubleshooting - Software.

Connecting the Device

After completing the scanner hardware installation and software installation, start the RVCManager software, a Device Management pop-up window will automatically appear. Click [Search], the pop-up window will show the list of found devices.

DeviceManagement_en

  • USB Scanner: Select one device in the list, click [Connect] in the upper right corner to complete the connection.

  • GigE Scanner: Select a device in the list, click [Auto Config] in Details → Settings to automatically assign IP addresses to the device, and then click [Connect] to complete the connection. You can also click [Manual Config], enter the IP address manually, and then click [Connect] in the upper right corner to complete the connection.

Tip

If the scanner does not connect normally, please check Troubleshooting. For operations related to the network configuration of computers, please refer to Advanced Topics - Network Configuration.

Capture

Preparation

  • Please check whether the scanner is in the working distance, avoid the scanner working range out of the calibrated range, otherwise the point cloud effect and accuracy can not be guaranteed.

  • Avoid using the scanner in an environment where there is strong direct light, such as sunlight, spotlights, and so on.

  • Please check whether the object to be captured is colorless or transparent.

  • Please do not knock the scanner or disassemble the scanner artificially.

  • Remove the protective film from the lens and light machine before use. If there is any dirt on the lens or the light machine, please clean it promptly with lens tissue and alcohol.

  • Keep the scanner and the object to be captured stationary during the capturing, avoid hand-held capturing.

Capturing

  • Capture Once: Click icon-3DCapture to complete the 3D single capture, you can get a single point cloud, depth map, 2D image, confidence map. Click icon-2DCapture to complete 2D single capture, you can get a single 2D image.

  • Capture Continuously: Acquire images at fixed intervals, generate data continuously, and modify parameters in real time at the same time. Click icon-3DContinuousCapture icon-2DContinuousCapture button to start 3D/2D continuous capture, click the icon again to stop capturing. 3D continuous capture can continuously acquire point cloud, depth map, 2D image and confidence map, 2D single capture can continuously acquire 2D image.

Data View

DisplayPointCloud_en

The point cloud or image can be viewed directly in the display area of the main interface. By using the icon-PointCloud icon-DepthMap icon-2DImage icon-ConfidenceMap icon-CaptureParameter button above, you can switch the display content to 3D point cloud, depth map, 2D image, confidence map or capture parameter information. By clicking the hover button above the display area, you can set the point cloud color, size, view angle, etc. and perform simple measurement operations. The basic operations of the view are as follows:

Function Operation
Rotate the point cloud Click the left mouse button to drag
Panning Click and drag the right mouse button
Zoom view Roll mouse wheel
Return to the initial viewpoint Press the space bar
Ranging and selecting points/selecting the center of rotation Click the middle mouse button

Tip

For more display settings, see RVCManager - Viewing Images, RVCManager - Point Cloud Display.

Judgement Basis for Capturing Effect

A good point cloud should meet the following conditions:

  • The point cloud and depth map are not obviously missing, and the effective points have a high fill rate in the field of view.

  • There is no obvious flying noise on the point cloud.

  • The point cloud data has a high degree of reproduction of the measured object, and there is no obvious deformation or bending.

Saving Data

You can save the data by using the menu bar → File → Save File, or by clicking the icon-SaveFile shortcut button. When saving the data, you can select the file types such as point cloud, depth map, 2D image, and cached data.

Adjusting Parameters

By adjusting the parameter settings, you can optimize the point cloud capturing effect.

InterfaceParameter_en

Tip

For parameter description and function demonstration, please refer to RVCManager User Manual - Parameter Settings, and for parameter adjustment FAQ, please check Advanced Topics - FAQs about Capture Parameter Adjustment.

2D Parameters

Generally, when the 2D image is too dark, you can increase Exposure2D and Gain2D, and select Yes for ProjectorEnable2D; when the 2D image is too bright, you can decrease Exposure2D and Gain2D; Gamma2D is seldom used, so it is recommended to keep it at the default value. Refer to the following table for capturing results:

Normal capturing Too dark Too bright
Point cloud 2DRegularPointCloud 2DUnderexposurePointCloud 2DOverexposurePointCloud
2D image 2DRegularImage 2DUnderexposureImage 2DOverexposureImage

3D Parameters

By looking at the solid color point cloud or depth map, you can quickly determine the missing point cloud. Blank areas in a solid color point cloud and black areas with NAN depth values in a depth map represent missing point clouds.

In general, when the point cloud is underexposed, you can increase Exposure3D, Gain3D and Brightness, and select Yes for ProjectorEnable2D; when the point cloud is overexposed, you can decrease Exposure3D, Gain3D and Brightness. If there is a large difference in the color or material of the items in the scene, or if there are reflective areas, you can capture in HDR mode. Take the calibration board as an example, the capturing effect can refer to the following table:

Normal capturing Underexposure Overexposure
Point cloud 3DRegularPointCloud 3DUnderexposurePointCloud 3DOverexposurePointCloud
Depth map 3DRegularDepthMap 3DUnderexposureDepthMap 3DOverexposureDepthMap

Post-processing

  • Denoising: If there is a lot of noise in the point cloud, you can adjust the denoising parameters (Clustering Denoising, Confidence Denoising, Z-Truncate, Edge Denoising, etc.) in Settings → Post-Processing Parameters on the right side of the main interface to optimize the quality of the point cloud.

  • Smoothing: Adjust the parameters of Smooth Level and Bilateral Filtering to smooth the point cloud.

Tip

RVCManager also supports downsampling, normal vector calculation, ROI setting and other operations on point cloud. Please refer to RVCManager - Post-Processing Parameters, RVCManager - Device Functions for parameter description and function demonstration.

Coordinate System Settings

Go to Settings → Coord Parameters on the right side of the main interface, you can switch between calibration board coordinate system/camera coordinate system/customer coordinate system. The customer coordinate system can be customized by modifying the offset value and rotation value, or selecting points with the Customer Quick Config function.

Tip

Please refer to RVCManager - Coordinate System Settings for the description of coordinate system setting and function demonstration.

Import and export parameters

  • Export Parameters: Go to Settings → Device Functions → Export Parameter File on the right side of the main interface, click [Execute] to export the capture parameters saved in the current device to a .json format configuration file.

  • Import Parameters: Go to Settings → Device Functions → Import Parameter File on the right side of the main interface, click [Execute] to import the parameter configuration file in .json format from the local path, and load the parameters in the file into the device.

Viewing the Log

  • View Logs: Go to the menu bar → Help → Logs to open the log folder. In case of malfunction, you can view the log to locate the problem or send the log to technical support.

  • Advanced Log: Go to the menu bar → Help → Generate Advanced Log, you can generate an advanced log from the raw data of the point cloud synthesized by the scanner and open the corresponding folder. If there is a quality problem with the point cloud captured by the scanner, you can send this data back to technical support.